Home > Can T Install > Can't Install My Mobility Radeon HD 5470

Can't Install My Mobility Radeon HD 5470

Then I re-installed Catalyst without success. I was manually unsinstalling drivers in safe mode in Device manager which was a pain, because there were many versions of drivers in driverstore and win7 automaticaly was bringing them back. SmilingLunatic View Public Profile Find all posts by SmilingLunatic (#6) dellon132 Maha Guru Videocard: HD 5570 1 GB DDR3 Processor: Intel E2180 3.2Ghz Mainboard: Asrock Memory: 3GB DDR2 Soundcard: The time now is 08:46. Check This Out

But if run VLC player withoutgraphic card, ot works well.I wish some AMD official can help me with this. Installed successfully with no errors except the backlight error, yes. If I manually select and try to install the driver for 7670M from the 15.200.1062.1004 list of adapters - Windows blocks this operation an states 7670M driver is not compatible.Looks this iampao View Public Profile Find More Posts by iampao 17 Nov 2013 #4 SandeepP Winndows 7 32 bit 1,007 posts New Delhi, India Quote: Originally Posted by https://www.eightforums.com/graphic-cards/14654-cant-install-my-mobility-radeon-hd-5470-a.html

Full backlight. Installed successfully with no errors except the backlight error, yes. I tried several times with drivers 13.6 beta, 13.10 beta and 13.9. I want to bring to your attention that this issue is affecting also Linux systems.

I'm running the sfc scan now. I tried disabling automatic drivers installation but didn't help either. My System Specs Computer type PC/Desktop OS Windows 7 Home Premium x64 . Still sucks that I have to keep the 'Test Mode' watermark but it beats not having proper drivers installed.

Catalyst center will not open. Everytime I try to switch to the other GPU, I am greeted with a black screen. Hope someone can help us! recommended you read From Disc or Amd Website or Manufactures Website ... ?

My laptop is “Sony Vaio VPCE C3S0E” I tried the link below but unfortunately the AMD says that the available drivers are NOT compatible with SONY VAIO... Any help would be appreciated. But, of course, without the backlight the system is unusable. None of the betas since after the 13.4 driver released have been working, and I've been doing clean uninstalls of old drivers, and clean installs of new ones.

I have a DV6 3020EP and for now, there isn't support for this graphic... more info here The setup installation is faulty and the Device Manager won't let me do it either. Reinstalled 13.9 driver, booted up. I am using a Gigabyte Windforce R9 290X and Windows 10 Like Show 0 Likes(0) Actions Re: AMD Catalyst 15.7.1 Issue Is Fixed At Last!!! :D akiekolove01 Sep 25, 2015 1:35

one more thing to check is in the control panel> System and security> system >advanced system settings>Hardware>device installation settings> select no and try to reinstall and see if that helps, it http://allwebsitescripts.com/can-t-install/can-t-install-net-framework-3-5.html It's using ATI Mobility Radeon HD 5470. I right click on the desktop and the 'ATI CATALYST' tab is on, when i click it on... Interested in folding with fellow gurus?

I upgraded to Windows 8 Pro recently but ever since I was not able to use this method in order to get my driver properly installed. keeps getting this randomly both while running a game and doing regular tasks in windows 10.Log Name: SystemSource: DisplayDate: 8/8/2015 11:30:42 PMEvent ID: 4101Task Category: NoneLevel: WarningKeywords: ClassicUser: N/AComputer: ZeusDescription:Display driver Please turn JavaScript back on and reload this page. this contact form But I could still see the error message using my phone flashlight, lol.

To clarify, 13.10 is doing this as well. Saying so, there's something wrong in the latest drivers that causes troubles with HD 5470 (and maybe all the HD 5000 serie?) in different OSs. It is possible that the Intel graphic card is causing the problem with blackscreen before the login screen for over 30 seconds?

Last edited by Shpati; 09-25-2013 at 22:12.

When i force to install driver manualy...aive got blue screens ATIKMSAG.SYS Then computer cannot start...only in safe mode.I tried everything...still no go. I have a fresh install of Windows 7 Home Premium x64 on ASUS X72DR. So I think this may be linked to the driver update backlight issue. Adv Reply January 21st, 2013 #6 Mark Phelps View Profile View Forum Posts Private Message Ubuntu Member Join Date May 2007 Location Virginia, USA Beans 13,240 DistroUbuntu Mate Development Release

My System Specs Computer type PC/Desktop OS Windows 7 Home Premium x64 LordJebe View Public Profile Find More Posts by LordJebe 28 Aug 2014 #6 maxie windows 7 home 64bit When I upgraded to Windows 8 Enterprise Evaluation, my Device Manager would show up my Display Adapter as "ATI Mobility Radeon HD Series 5000 - (Microsoft Corporation WDDM v1.20) When I I'm going to try that later tonight. navigate here It would be on AMD's end.

Restoring my windows to previous restore point ( still got black screen after boot )2. I'm guessing that means it's a backlight issue. anotherAMDuser, most just tell me the same thing. After many issues, I disabled the Intel HD Graphics and I'm making due with just my HD 5470.

but black screen alaways appears on windows log.on screen .now this idea I want to share go to Start - Control Panel look for Device Manager - Display Manager .. This has happened for me with the AMD 13.6 - 13.10 beta drivers. This is the case.